首页

时间和精神的房子
壹只iOS程序员的修行世界,欢迎来访

如果文章对您有所帮助
将是我最大的荣幸

CocoaPods建立自己的Podspec(三)

创建自己的 Pod 十分简单。只需要创建 .podspec,编辑好 .podspec 的必要信息,提交到 Git,然后就可以在其他项目中使用了。

如果想了解其中的原理,可以查看这篇文章。

如果是 Swift ,可以在此基础上参考这篇文章。

创建.podspec

首先在你的项目中使用如下命令创建名为 LPPushService 的 LPPushService.podspec(当然你也可以使用vim创建,只是没有默认文本而已)

$ pod spec create LPPushService

编辑.podspec

创建好的 .podspec 包含大量的注释说明了每个参数的含义及用法。如果想详细了解可以仔细阅读。这里只介绍几个常用的。

Pod::Spec.new do |s|

  s.name                = "LPPushService"
  s.version             = "1.0.0"
  s.summary             = "integrate APNs rapidly"
  s.homepage            = "https://github.com/xiaofei86/LPPushService"
  s.license             = { :type => "MIT", :file => "LICENSE" }
  s.author             = { "XuYafei" => "xuyafei86@163.com" }
  s.social_media_url   = "http://xuyafei.com"
  s.platform            = :ios, "7.0"
  s.source              = { :git => "https://github.com/xiaofei86/LPPushService.git", :tag => s.version }
  s.source_files        = "LPPushService/**/*.{h,m}"
  s.resources          = "LPPushService/Images/*.png"
  s.dependency          "BPushSDK", "1.4.1"
  s.requires_arc        = true

end

s.name:名称,pod search 搜索的关键词
s.version:版本
s.summary:简介,pod search 搜索的关键词
s.homepage:主页地址,例如Github地址
s.license:许可证
s.author:作者
s.social_media_url:社交网址
s.platform:平台
s.source:Git仓库地址,例如在Github地址后边加上 .git 就是Git仓库地址,常见写法如下
s.source_files:需要包含的源文件,常见的写法如下
s.resources:需要包含的图片等资源文件
s.dependency:依赖库,不能依赖未发布的库
s.dependency:依赖库,如有多个可以这样写
s.requires_arc:是否要求ARC

s.source_files 常见写法

"Directory1/*"
"Directory1/Directory2/*.{h,m}"
"Directory1/**/*.h"
  • “*” 表示匹配所有文件
  • “*.{h,m}” 表示匹配所有以.h和.m结尾的文件
  • ” 表示匹配所有子目录

s.source 常见写法

s.source = { :git => "https://github.com/xiaofei86/LPPushService.git", :commit => "68defea" }
s.source = { :git => "https://github.com/xiaofei86/LPPushService.git", :tag => 1.0.0 }
s.source = { :git => "https://github.com/xiaofei86/LPPushService.git", :tag => s.version }
  • commit => "68defea" 表示将这个Pod版本与Git仓库中某个commit绑定
  • tag => 1.0.0 表示将这个Pod版本与Git仓库中某个版本的comit绑定
  • tag => s.version 表示将这个Pod版本与Git仓库中相同版本的comit绑定

按照上述规则编辑完成就制作好了 .podspec(最好使用vim进行编辑)。

上传到Git

将包含配置好的 .podspec 的项目提交 Git,并给这次提交打上 tag,这时就可以在其他项目中使用 CocoaPods 引入你配置好的 Pod 了。

pod 'LPPushService', :git => 'https://github.com/xiaofei86/LPPushService.git', :tag => '1.0.0'

当然,在给其他项目使用前最好先*验证.podspec的有效性。

*验证.podspec

编辑好后最好先验证 .podspec 是否有有效

$ pod spec lint LPPushService.podspec

验证过程中:

 -> LPPushService

验证成功后:

LPPushService.podspec passed validation.

验证失败后:

[!] The spec did not pass validation, due to 1 error.

验证 .podspec 会先测试本地 .podspec 文件是否存在语法错误。测试成功再根据 .podspec 文件找到远端仓库对应的版本克隆到本地并进行配置。最后测试文件是否能够编译成功。

*.podspec验证失败错误排查

语法错误

如果是因为语法错误,验证失败后会给出错误的准确定位

[!] Invalid `LPPushService.podspec` file: no .<digit> floating literal anymore; put 0 before dot
  s.version      = “1.0.0”
                        ^
LPPushService.podspec:5: syntax error, unexpected tFLOAT, expecting '('
  s.version      = “1.0.0”
                           ^

标记“^”的地方即为有语法错误的地方。

上述错误是因为使用“文本编辑”进行编辑造成的。使用文本编辑有时候英文""引号会自动变成中文“”引号。

[!] Your Podfile has had smart quotes sanitised. To avoid issues in the future, you should not use TextEdit for editing it. If you are not using TextEdit, you should turn off smart quotes in your editor of choice.

使用 vim 将其改为英文的""引号即可。

依赖错误

但是,有些非语法错误是不会给出错误原因的。这个时候可以使用“--verbose”来查看详细的验证过程来帮助定位错误。

pod spec lint LPPushService.podspec --verbose

如下错误通过 --verbose 就可以找到原因。

 -> LPPushService (1.0.0)


    - ERROR | [iOS] Encountered an unknown error (The 'Pods' target has transitive dependencies that include static binaries: (/private/var/folders/jz/b_m3k7ln47524cm__h3__mk00000gn/T/CocoaPods/Lint/Pods/BPushSDK/LibBPush/libBPush.a)) during validation.

这个错误是因为依赖库(s.dependency)包含了.a静态库造成的。虽然这并不影响Pod的使用,但是验证是无法通过的。可以通过 --use-libraries 来让验证通过。

pod spec lint LPPushService.podspec --verbose --use-libraries

这种情况下使用 --use-libraries 虽然不会出现错误(error),但是有时候会带来一些警告(waring),警告同样是无法通过验证的。这时可以用 --allow-warnings 来允许警告。

pod spec lint LPPushService.podspec --verbose --use-libraries --allow-warnings

安装错误

如果在其他项目 pod install 的过程中,出现包含“undefined method `end_with?' for nil”字样的报错。进入“~/.cocoapods/repos”目录,删除“master”,并将 master-1 改为 master 即可。

如果出现如下错误,而你的验证可以通过,那么一般更新下版本号就可以解决。

[!] Unable to find a specification for 'LPPushService'.

再次验证

如果错误发生在 .podspec 中。当修改完时,不需要再次提交就可以直接验证。如果错误发生在代码中,则需要再次提交才能验证。

发布到CocoaPods

你可以用 .podspec 文件来方便的管理内部代码,当然,也可以发布自己的 Pod 供其他开发者使用。

CocoaPods 0.33中加入了 Trunk 服务,使用 Trunk 服务可以方便的发布自己的Pod。虽然一开始使用 GitHub Pull Requests 来整理所有公共 pods 效果很好。但是,随着 Pod 数量的增加,这个工作对于 spec 维护人员 Keith Smiley 来说变得十分繁杂。甚至一些没有通过 $ pod lint 的 spec 也被提交上来,造成 repo 无法 build。CocoaPods Trunk 服务的引入,解决了很多类似的问题。每次使用 Trunk 服务发布 Pod 时都会通过 $ pod lint 验证 .podspec 是否有效。要想使用 Trunk 服务,首先需要使用如下命令注册自己的电脑。这很简单,只要你指明你的邮箱地址(spec文件中的)和名称即可。CocoaPods 会给你填写的邮箱发送验证邮件,点击邮件中的链接就可通过验证。

pod trunk register xuyafei86@163.com "XuYafei"

然后就可以发布你的 Pod 了。

pod trunk push LPPushService.podspec

发布时会验证 Pod 的有效性,如果你在手动验证 Pod 时使用了 --use-libraries 或 --allow-warnings 等修饰符,那么发布的时候也应该使用相同的字段修饰,否则出现相同的报错。

pod trunk push LPPushService.podspec --use-libraries --allow-warnings

发布成功后,就可以使用 pod search 搜索到你的 Pod 了!

-> LPPushService (1.0.0)
   integrate APNs rapidly
   pod 'LPPushService', '~> 1.0.0'


   - Homepage: https://github.com/xiaofei86/LPPushService
   - Source:   https://github.com/xiaofei86/LPPushService.git
   - Versions: 1.0.0 [master repo]

由于 pod search 是搜索的本地“~/.cocoapods”,所以在其他设备上可能无法搜到。这时只需要执行 pod install 更新下 pod 仓库即可(不要加 --no-repo-update)。

版本升级

当需要更新 Pod 版本的时候,修改 .podspec 中的 s.version 为更高的版本号,并修改 s.source 中对应的 Git 版本。提交到Git,并打上对应tag。然后再次执行pod trunk push LPPushService.podspec将新的 .podspec 发布到 CocoaPods。更新完成!

为了更新更加方便,版本控制更加清晰,s.source 建议采用如下写法:

s.source = { :git => "https://github.com/xiaofei86/LPPushService.git", :tag => s.version }

这样写将 Git 的版本与 CocoaPods 的版本进行了绑定。每次提交后再给本次提交打上 tag 就完成了更新。而且在 Git 中就可以清晰的看到哪次提交对应的哪个 CocoaPods 版本。如果与 commit 绑定,则要通过两次提交才能完成更新,第一次先提交修改代码,第二次将上一次 commit id 更新到 s.source 然后再次提交。如果直接与固定 tag 绑定,则每次还都要修改 s.source。如果你的 Pod 是私有库,那么 s.source 其实是无用的。因为在 Podfile 中已经指明了地址和版本(如下)。这时 s.source 可以随便填写,但最好还是按照上述规则以便以后发布。

pod 'LPPushService', :git => 'https://github.com/xiaofei86/LPPushService.git', :tag => 1.0.0

删除已发布的Pod

pod trunk delete LPPushService 1.0.1

在执行删除命令时CocoadPods会询问是否真的要删除,这时输入 yes 即可。

WARNING: It is generally considered bad behavior to remove versions of a Pod that others are depending on!
Please consider using the `deprecate` command instead.
Are you sure you want to delete this Pod version?
> yes
[!] The version is already deleted.

删除 Pod 是一个很不友好的行为,因为如果还有人依赖你的删除的版本则无法进行 pod update/install 操作。

参考资料

关注作者

分享本文

目录